Board Outage 4/17/2013

Discussions specifically relating to the operation of this forum, suggestions, problems, etc.

Board Outage 4/17/2013

Postby xjrguy » Wed Apr 17, 2013 7:54 pm

All,

A stupid system update I ran remotely from the office took my SAN offline. I had to roll it back but that had to wait until after work today.

It's resolved now.

Nothing was lost, there just was no access to the forum for almost the entire workday because the SAN (where the forum resides) was offline and couldn't connect to the host (the server)

Note to self, don't run updates remotely, even supposed non threatening ones like a Java update (which my ISCSI SAN initiator depends on!)


Sorry for the inconvenience but we are good to go now.

XJRGUY
2015 Prius Five
2016 Challenger Hellcat
2016 Grand Cherokee Summit EcoDiesel
2012 Jeep Rubicon Unlimited AEV Upgrades
1973 Lincoln Continental Coupe 460/C6
2010 Kawasaki Concours 1400 ABS with some farkles
User avatar
xjrguy
Site Admin
 
Posts: 840
Joined: Tue Jul 22, 2008 12:14 am
Location: The Garage
Has thanked: 40 times
Been thanked: 1 time

Re: Board Outage 4/17/2013

Postby Brakelate » Thu Apr 18, 2013 12:07 pm

We are all probably a bit jumpy, after our last internet crash pad burned to the ground overnight, leaving no trace or remains of over ten years of foolishness.

So, it did give me a bit of a scare. But, I am glad to see all is well.

I'd take the opportunity to once again thank you for having us, and letting us spill things of the floor, kick our feet up on the furniture and overall get comfy in your impressive virtual "Man Cave".

Thanks Again!

Jay




*Hey, not to get all mushy and everything, but it might be nice to set a date this summer for a "ride-in, drive-in BBQ get together" or something so we can put faces with the names, screen names, nicknames and various vehicles.
User avatar
Brakelate
Third Gear
 
Posts: 1403
Joined: Fri Sep 12, 2008 1:44 am
Location: UT / AZ Border overlooking Lake Powell
Has thanked: 20 times
Been thanked: 11 times

Re: Board Outage 4/17/2013

Postby the1904kid » Thu Apr 18, 2013 12:29 pm

yea the email blast you sent out was nicely appreciated. I figured the worst, like Brakelate said, but am glad it really was nothing.

if only all of these geezers would join Facebook, they could get in on all the other internet fun, but I guess you really can't teach an old dog new tricks! :dance:
2006 CRF450R Supermoto
2004 CRF450R Dirt/Desert Machine
2007 DRZ400SM Streetard
User avatar
the1904kid
Noob
 
Posts: 66
Joined: Sat Mar 30, 2013 3:33 pm
Has thanked: 0 time
Been thanked: 3 times

Re: Board Outage 4/17/2013

Postby xjrguy » Thu Apr 18, 2013 5:13 pm

Here are the four things that will normally cause a board outage.

1. Me doing maintenance on the server which is usually a quick reboot. The server reboots in about a minute or two. Planned and extended outages will be posted on the board. Unfortunately the one yesterday was unplanned and extended because it was a simple Java update - who knew it would blow up the ISCSI initiator. LOL (what is funny is the vendor of the SAN didn't even know and I had to provide them the fix!)
2. The internet line going down or the ISP doing maintenance for some reason (modem flash updates, etc) - usually the planned stuff they do is very late at night/early mornings. We are hosted on a business grade line which is a plus.
3. The power going out. All the equipment is on UPS battery backup, but once that is exhausted the server and all equipment gracefully shuts down. It powers back on when line power is re-established.
4. Hardware failure on the server. We have a pretty redundant system here. Everything is on RAID volumes, then replicated to another external SAN, and then replicated offsite to a cloud based colocation facility. We can have several hard drive failures without missing a beat.

If there is a problem, I will do everything I can to communicate the issue and status...because even though you guys don't pay for any of this (and I never would solicit money, donations, or even put ads here - not in it for the money at all) you are still, to me, considered my clients. :)

The facility the server is located at could burn down and the board could be back up and running in hours on another machine based on the last known good backup which is scheduled on a very tight schedule.

The other major plus is I own and physically maintain each and every piece of equipment running this forum. If something happens, I am right in front of the gear and not beholden to another company or hosting firm.

I guess the point is, even when the board was dead with absolutely no activity other than me deleting the spam bot accounts that tried to get on here, I kept it running and maintained (even updating the PHPBB version as new releases came out) and we have really good backups.

Enjoy!!

I am very glad everyone is here, having fun, doing their thing.

:)
2015 Prius Five
2016 Challenger Hellcat
2016 Grand Cherokee Summit EcoDiesel
2012 Jeep Rubicon Unlimited AEV Upgrades
1973 Lincoln Continental Coupe 460/C6
2010 Kawasaki Concours 1400 ABS with some farkles
User avatar
xjrguy
Site Admin
 
Posts: 840
Joined: Tue Jul 22, 2008 12:14 am
Location: The Garage
Has thanked: 40 times
Been thanked: 1 time


Return to LA Speed Garage Discussions and Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron